Project

General

Profile

Bug #93

horse mounting bug

Added by Backer curtisaurus over 3 years ago. Updated over 3 years ago.

Status:
Investigating
Priority:
Normal
Assignee:
-
Steam or Launcher:

Description

I had just started a new game and was riding the horse around, experimenting with both the controller and keyboard settings. I dismounted, and then while standing right next to the horse (maybe too close) I pressed "Y" on the xbox controller, which called the horse and sort of mounted it. Instead of my character POV being atop the horse, it is at waist level just beside the horse on it's left side where I had been standing when I called the horse.

So the character model is tied to the horse and we run around together as if it were mounted, even though its more like I'm being dragged alongside. The main problem is that I'm unable to "dismount" from this state. Pressing the controller "Y" or keyboard X again just called the horse again as if I were already dismounted.

History

#1 Updated by Daniel Zadák over 3 years ago

  • Status changed from New to Investigating

Backer curtisaurus wrote:

I had just started a new game and was riding the horse around, experimenting with both the controller and keyboard settings. I dismounted, and then while standing right next to the horse (maybe too close) I pressed "Y" on the xbox controller, which called the horse and sort of mounted it. Instead of my character POV being atop the horse, it is at waist level just beside the horse on it's left side where I had been standing when I called the horse.

So the character model is tied to the horse and we run around together as if it were mounted, even though its more like I'm being dragged alongside. The main problem is that I'm unable to "dismount" from this state. Pressing the controller "Y" or keyboard X again just called the horse again as if I were already dismounted.

Hi curtisaurus,

is this easily reproducable? We tried it but no success reproducing it. Would it be possible to attach a video?

Cheers

Daniel

#2 Updated by Backer curtisaurus over 3 years ago

For better or worse, I could not reproduce the bug when I tried today either. Instead, it seemed like a different collision model was enabled with the horse, because when I tried to stand too close to the horse, my character would bump into it and take a stamina hit. This is something I did not notice when I was playing before. I think because of this, I am now unable to "call" the horse (press X and hear my character whistle) while standing right next to (or inside of) the horse. This was characteristic of the bug I was seeing, but I'm not seeing that anymore.

Maybe updated game software was installed since I was playing before. I thought I was on the latest 3.7G version, but maybe it wasn't.

version.txt says I'm on beta_release_8.1_77563_965. Unfortunately I didn't check this file before when I saw and logged the bug so I can't say whether it the same version or not.

#3 Updated by Backer curtisaurus over 3 years ago

So after playing a bit more, I actually was able to reproduce the bug on beta_release_8.1_77563_965. I have not been able to reproduce it with the keyboard controls, only using my xbox controller. One clue may be I just realized my xbox controller for some reason has both the call/mount horse and "jump" buttons mapped to the same button (Y) so this may be related to the root cause.

So to reproduce, I start a new game and, using the controller with this peculiar mapping scheme, I run around a little (this seems to be key) dismount and then try to mount.

Anyway, here is some video. Notice that when I try to mount, my character whistles to call the horse, and the horse jumps at the same time, again suggesting that the controller button mapping may be related to the issue.

https://goo.gl/photos/2N4cA4U2LmdTjFJW6

https://goo.gl/photos/3xpnj7ybtVK2FQQQ7

#4 Updated by Daniel Zadák over 3 years ago

Just a noob question, how do you map the jump function onto the Y button? Or you can actually jump using the Y button without tampering with anything?

Thank you

Daniel

#5 Updated by Backer curtisaurus over 3 years ago

Good question. I'm running an Alienware Alpha on Windows 8 that shipped with an xbox controller. Out of the box it had this wonky key mapping or possibly driver issue with the controller, and I've read about others people with similar setup and similar issues. It would seem there's a simple fix but I haven;t managed to figure it out yet. And the problem is subtle enough that usually don't even notice it.

But you'd think that a PC marketed as a games-ready console running preinstalled Microsoft Windows 8 would be able to work seemlessly with the Microsoft Xbox controller that shipped with it, right??

#6 Updated by Backer erondell over 3 years ago

Hey there!

I've got this issue exactly the same way. I was in that military camp and did my sword traning etc. I was just near to my horse and pressed X (Mount/Call Horse) it didn't do the mount animation but i was moving with the horse. But the thing is, horse was on my left side and i was able to move the camera like i was on foot.(When on horseback, you can rotate the camera just a bit to the left and to the right you know.) and i was able to see my character's body when i turn the camera but the character had no head.

I just tried to double shift to tire the horse and press X several times but nothing happened, just whistling over and over and just ran with horse.

Also available in: Atom PDF