Project

General

Profile

Support #79

Launcher bundle setup error 0x3E8

Added by Backer hasso50 over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal

Description

Hi,
I have just bought Collector’s Edition and download BETA launcher, but unfortunately I recived 'bundle setup error 0x3E8'
Please help :)
hasso50

k error.JPG (162 KB) Backer hasso50, 03/19/2016 03:39 PM

KCD_Beta_Access_20160322172853.log Magnifier (3.58 KB) Backer hasso50, 03/22/2016 05:31 PM

History

#1 Updated by Daniel Zadák over 2 years ago

Backer hasso50 wrote:

Hi,
I have just bought Collector’s Edition and download BETA launcher, but unfortunately I recived 'bundle setup error 0x3E8'
Please help :)
hasso50

Hi hasso50,

to further analyze, what the issue is, we would need you to provide us with n launcher instalation log.

How do you get the log? Simply open file explorer and type %temp% and you will be redirected to the appropriate folder. Here, you have to locate the log. In this folder you will see a text file: KCD_Beta_<date_and_time>.log

Possibly upload it here and we can investigate the issue further.

Cheers

Daniel

#2 Updated by Daniel Zadák over 2 years ago

  • Status changed from New to Investigating
  • Assignee set to Miroslav Louma

#3 Updated by Backer hasso50 over 2 years ago

Thank you for the info

[063C:158C][2016-03-22T17:28:52]i001: Burn v3.10.2.2717, Windows v6.1 (Build 7600: Service Pack 0), path: E:\TMP\684807313c574746bd5f7f8b3e94bc91\bc712d0872df4f8bacf8246aafa22658.tmp
[063C:158C][2016-03-22T17:28:52]i000: Initializing string variable 'InstallationFolder' to value '[ProgramFilesFolder]Warhorse Studios\KCD Beta Access'
[063C:158C][2016-03-22T17:28:52]i009: Command Line: '-burn.embedded bpe_0d3d0c744af54d9d979bf711ee2a6522 d8537fbac8f646d8b675419718f43018 4108 "InstallationFolder=C:\Program Files (x86)\Warhorse Studios\KCD_Beta"'
[063C:158C][2016-03-22T17:28:52]i000: Setting string variable 'WixBundleOriginalSource' to value 'E:\TMP\684807313c574746bd5f7f8b3e94bc91\bc712d0872df4f8bacf8246aafa22658.tmp'
[063C:158C][2016-03-22T17:28:52]i000: Setting string variable 'WixBundleOriginalSourceFolder' to value 'E:\TMP\684807313c574746bd5f7f8b3e94bc91\'
[063C:158C][2016-03-22T17:28:53]i000: Drive for volume F:\ is not suitable (5), skipping.
[063C:158C][2016-03-22T17:28:53]i000: Drive for volume G:\ is not suitable (5), skipping.
[063C:158C][2016-03-22T17:28:53]i000: Setting string variable 'WixBundleLog' to value 'E:\TMP\KCD_Beta_Access_20160322172853.log'
[063C:158C][2016-03-22T17:28:53]i000: Setting string variable 'WixBundleName' to value 'KCD Beta Access'
[063C:158C][2016-03-22T17:28:53]i000: Setting string variable 'WixBundleManufacturer' to value 'Warhorse Studios'
[063C:158C][2016-03-22T17:28:53]e000: Error 0x81f403e8: The Burn engine cannot run with an MBA under the .NET 4 CLR on Windows 7 RTM with .NET 4.5.2 (or greater) installed.
[063C:158C][2016-03-22T17:28:53]i000: Loading prerequisite bootstrapper application because managed host could not be loaded, error: 0x81f403e8.
[063C:0C18][2016-03-22T17:28:53]i000: Setting string variable 'InstallationFolder' to value 'C:\Program Files (x86)\Warhorse Studios\KCD_Beta'
[063C:0C18][2016-03-22T17:28:53]i000: Setting numeric variable 'WixStdBALanguageId' to value 1045
[063C:0C18][2016-03-22T17:28:53]i000: Setting version variable 'WixBundleFileVersion' to value '2.0.0.0'
[063C:158C][2016-03-22T17:28:53]i500: Shutting down, exit code: 0x3e8
[063C:158C][2016-03-22T17:28:53]i000: The prerequisites were not successfully installed, error: 0x81f403e8. The bootstrapper application will be not reloaded.
[063C:158C][2016-03-22T17:28:53]i410: Variable: InstallationFolder = C:\Program Files (x86)\Warhorse Studios\KCD_Beta
[063C:158C][2016-03-22T17:28:53]i410: Variable: WixBundleAction = 5
[063C:158C][2016-03-22T17:28:53]i410: Variable: WixBundleElevated = 1
[063C:158C][2016-03-22T17:28:53]i410: Variable: WixBundleFileVersion = 2.0.0.0
[063C:158C][2016-03-22T17:28:53]i410: Variable: WixBundleInstalled = 0
[063C:158C][2016-03-22T17:28:53]i410: Variable: WixBundleLog = E:\TMP\KCD_Beta_Access_20160322172853.log
[063C:158C][2016-03-22T17:28:53]i410: Variable: WixBundleManufacturer = Warhorse Studios
[063C:158C][2016-03-22T17:28:53]i410: Variable: WixBundleName = KCD Beta Access
[063C:158C][2016-03-22T17:28:53]i410: Variable: WixBundleOriginalSource = E:\TMP\684807313c574746bd5f7f8b3e94bc91\bc712d0872df4f8bacf8246aafa22658.tmp
[063C:158C][2016-03-22T17:28:53]i410: Variable: WixBundleOriginalSourceFolder = E:\TMP\684807313c574746bd5f7f8b3e94bc91\
[063C:158C][2016-03-22T17:28:53]i410: Variable: WixBundleProviderKey = {8652d5cc-8bbf-4bfd-8721-eceffb8f0090}
[063C:158C][2016-03-22T17:28:53]i410: Variable: WixBundleTag =
[063C:158C][2016-03-22T17:28:53]i410: Variable: WixBundleVersion = 2.0.0.0
[063C:158C][2016-03-22T17:28:53]i410: Variable: WixStdBALanguageId = 1045
[063C:158C][2016-03-22T17:28:53]i007: Exit code: 0x3e8, restarting: No

Cheers!

#4 Updated by Miroslav Louma over 2 years ago

  • Status changed from Investigating to Resolved

Thank you for posting the log file. By analyzing it, we've found the cause of installation failure.

As per download page for .NET Framework 4.5.2 below, it is not supported on Windows 7 RTM version (even though the installation is allowed).

https://www.microsoft.com/en-us/download/details.aspx?id=42643

Supported Operating System

Windows 7 Service Pack 1, Windows 8, Windows 8.1, Windows Server 2008 R2 SP1, Windows Server 2008 Service Pack 2, Windows Server 2012, Windows Server 2012 R2, Windows Vista Service Pack 2

As a result, our installation subsystem won't work in such configuration. We recommend installing Service Pack 1 for Windows 7. It might be necessary to reinstall .NET Framework afterwards (though you certainly can try installing the beta before doing that).

#5 Updated by Backer hasso50 over 2 years ago

It's working! Thank you.
Cheers

Also available in: Atom PDF