Project

General

Profile

Bug #769

The Rocketeer, Urban and infinite loading bug = main quest stucked

Added by Backer turielo about 1 year ago. Updated about 1 year ago.

Status:
New
Priority:
Normal
Assignee:
-
Steam or Launcher:
Steam

Description

I've already posted a subject regarding the issue with Urban (Issue #747), but now I'm dealing with Konrad Kyeser, the problem seems worst. So here are the details step by step of the bug I encounter:

-early game, I'm just travelling, doing side quests. I haven't even met Radzig in Rattay. So sir Divish gave me this side quest House of God which leads me to the Monastery for the first time. There, during investigation, I meet Urban, the soldier guarding the exterior door of the estate in the courtyard. He gives me the quest Saintly Remains. I already picked the bowl (relic) in the Monastery cavern prior to that, unaware of its use. So I present it to Urban and he told me to put it back in place.

-I continue travelling, I forgot completely about the Saintly Remains quest and don't put back the relic in the cave.

-I go back to the monastery much later, doing the quest to save Merhojed. There, I got attacked by Urban who treat me like a thief (as I forgot to put back the relic). FIRST MAJOR BUG: he's invicible, and win the fight leaving me with a health at zero but still able to play the game except I can't restore my health or stop the bleeding. Urban after the fight acts neutral with default dialogue. Saintly Remains is marked as completed. Only solutio I've found to avoid this encounter was to sneak in the estate by night and murder him. Urban is dead, the quest Saintly Remains is marked completed, no more bug. (detail: "Saintly Remains: Invicible Urban turning Henry to a zombie!" Issue #747)

-Later again, I was stealing all over the Monastery, and I broke into the estate that Urban guarded (now dead so absent). I stole everything in every room including the office of Konrad Kyeser (note that I didn't knew at all at the time about Konrad or the quest related to him). The office is empty (noone inside) and the building is not labelled as private, so I can move in freely.

-All my playthrgough until the start of my search for Konrad (triggered by the Rocketeer quest) Urban is still dead and so the estate unguarded in front of the exterior door. No bug, no nothing. I followed the bounty quest given by sir Sebastian without encoutering any problem, Urban (still dead) or Konrad.

-I begin the Rocketeer. SECOND BUG: Urban is back alive in front of the estate. Problem is, even with Saintly Remains marked as complete, he automatically attacked me, however this time I could surrender. He stopped fighting but if I speak to him he call me thief again because of the relic and attack me. This time I can't say if the zombie thing would occur, as I got a black screen with only Urban's taunt in background. To avoid being stuck by him, I killed him again with my bow.
Note that I still had the bowl (relic) on me because as Saintly Remains was completed I completely forgot about it, also Urban's body vanished after few minutes where corpses usually remain for longer (I didn't slept or anything, just walked around waiting for the alert to cool down). So no more Urban (again). I've updated my Issue report #747 with those details. Finaly, note that I didn't knew I was supposed to speak with Urban for the Rocketeer quest.

-Unlike the first time, I shot Urban with my bow, triggering an alarm of everyone around. Including Konrad who fled and remained on the bridge of the Monastery, so I was able to talk to him without introduction and pursue the quest. I didn't get caught so no trouble with any guards. So I could follow the quest without issue, even with Urban dead and missing.

-THIRD MAJOR BUG: at the end of the Rocketeer quest, I met Feyfar in front of the door by night as intended. Konrad was back inside his office. When I entered the office, a cutscene happened as if I meet Konrad for the first time. After the cutscene, I got stucked in an infinite loading, making me unable to complete the quest, therefor I suppose to pursue the main quest is not possible either. I've noted that during day, there is another guard inside, guarding the door leading to Konrad office, and the estate is labelled as private area, unlike before the quest started (I looted the office before, talked plenty of time with Sebastian, etc..). I tried to lure Konrad again outside by killing someone, but it didn't happened.

So in short: If the relic is not put back in place during Saintly Remains, after a while Urban called Henry a thief and attack him. As he's bugged and impossible to reason or kill, the only option is to kill him. To kill him however seems to bug the final stage of the Rocketeer (or even the start if Konrad hadn't left out?). Or the infinite loading after the Konrad's intro cutscene is another bug?

I searched for a workaround but only found people with the same issue, a lot with a link with Urban killed off because of Saintly Remains and the relic not put back in place. I tried to load old saves, nothing change. the only reloading I didn't tried was before even starting Saintly Remains because as it was very early in the game I had to basically start all over again and mostly because I didn't even knew how important Urban would be.

Now outside the very problem of the bug, I was surprised with Urban to not have any option during dialogue to avoid fighting him (no persuasion, no bribe, nothing. The dialogue leads to the fight no matter what), and I think it's wrong, it should be an option for Henry to settle the problem peacefully... Also it is weird that Urban was here from the beginning but not Konrad or that his office can be entered by lockpicking. By doing so, the player is unaware of the connection between Urban and Konrad, leading to killing the wrong person. Those are suggestions, as I don't know what triggered the bugs (Urban's invicibility, the infinite loadings and so on), so unless other bugs that can be solved with an other way of doing, there is no other way here... In those kind of games it is easy to forget a quest, especially when there is no real indication that a timing is set. So this is quite unfair to stuck the player with fighting Urban if he/she forget to put the relic back where it belongs. Don't get me wrong, I love this game, but this particluiar event, regarding of the bugs, felt wrong to me. It should be alternate options to deal with.

Hope this can be fix (so I don't have to start all over again...)!
Cheers!

History

#1 Updated by Backer turielo about 1 year ago

EDIT: I tried one more time to get past this quest. I don't know if reloading my previous save (right after dealing with Feyfar) was helping, but it worked. I just had to silently shoot the second guard posted inside the house at the door of Konrad's office, and wait for someone to find the body (I was hiding behind the small chapel of the garden to avoid being caught). Eventually Konrad will flee outside when someone call the guards after finding the body. I was able to talk to him and finish the quest.
I'm happy to be able to continue the game, yet I hope the bugs I reported here will be fix... This is a real trap!

Also available in: Atom PDF