Project

General

Profile

Bug #430

Launcher does nothing

Added by Backer mailpip over 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Normal
Steam or Launcher:
Launcher

Description

Downloaded on Windows 10 - shows up in downloaded files. Double click to execute... nothing happens. Right click and try to open as administrator, nothing happens. Have tried dl'ing a new copy, same result. What information do you need from me?

GameLauncher_20160717_124737_1451592.log Magnifier (1005 Bytes) Simon sire404, 07/17/2016 12:50 PM

security settigns.png (15.7 KB) ProkyBrambora (QA Team), 07/18/2016 10:58 AM

GameLauncher_20160717_124737_1451592.log Magnifier (1005 Bytes) Backer crapsody, 07/25/2016 06:19 PM

DxDiag.txt Magnifier (73.6 KB) Backer crapsody, 07/26/2016 04:47 PM

Windows Event.evtx (68 KB) Backer crapsody, 07/26/2016 06:12 PM

History

#1 Updated by ProkyBrambora (QA Team) over 2 years ago

  • Status changed from New to Investigating

hi there,
This issue seem like there is some problem on your side.
Are you able to start other .exe files or install other software?

Also, do you have any other device on which you could try to download and start the launcher?

#2 Updated by Simon sire404 over 2 years ago

I have the same problem. See attached log.
I had the game installed several months ago. Tried to install the new version, launcher just exits immediately after UAC.

#3 Updated by Tomáš Grünwald over 2 years ago

Simon sire404 wrote:

I have the same problem. See attached log.
I had the game installed several months ago. Tried to install the new version, launcher just exits immediately after UAC.

The both logs are complete garbage. But strangely similar...
Hard to tell what happened - what URL You used to download?

#4 Updated by ProkyBrambora (QA Team) over 2 years ago

@mailpip

Do do you have by any chance read only security settings on the folder from which you are trying to start the launcher?
You need to have "read and execute" settings. See attached picture.

#5 Updated by Simon sire404 over 2 years ago

ProkyBrambora (QA Team) wrote:

@mailpip

Do do you have by any chance read only security settings on the folder from which you are trying to start the launcher?
You need to have "read and execute" settings. See attached picture.

I downloaded the official launcher from the user area. Tried several times. Ran launcher in different folders, the temp dir, desktop etc. Verified security settings (read and execute). Since the installer requires administrator rights, this is unlikely the problem however.

#6 Updated by ProkyBrambora (QA Team) over 2 years ago

So to make one thing clear.
You both don have any problem with installation of other software?

I dont really have any reasonable ideas.

make sure you have latest SP for windows
update/reinstall windows installer
update drivers
do clean boot (https://support.microsoft.com/kb/929135) and try install again

#7 Updated by Backer crapsody over 2 years ago

Having the same issue here!
Other .exe files are working. The launcher doesnt even show up in the taskmanager.....

#8 Updated by ProkyBrambora (QA Team) over 2 years ago

  • Assignee set to Miroslav Louma

As Mirek is back, he might have some ideas?

#9 Updated by Backer crapsody over 2 years ago

Backer crapsody wrote:

Having the same issue here!
Other .exe files are working. The launcher doesnt even show up in the taskmanager.....

#10 Updated by Backer crapsody over 2 years ago

A simple would be to get an steam code for the beta but these codes are only for kickstarter backer, am i right? :/

#11 Updated by Miroslav Louma over 2 years ago

Since only sire404 has uploaded log file, I can only say what is wrong in his case. The others might be affected by the same problem, but that cannot be confirmed until they provide their log files.

As for sire404, the problem seems to be with the system itself. It looks like the game has already been installed, just there is no information on installation folder or installed version.

We will update the launcher to give a meaningful message in this case. However, the problem remains. Since we do not know how much data related to game installation is located in Windows Registry, it will be difficult to find a workaround for this issue (and no, simply searching and deleting anything related to Kingdom Come or Warhorse Studios is not going to help).

#12 Updated by Backer crapsody over 2 years ago

For me its not possible to attach a logfile because when i doubleclick the launcher exe, there is no reaction at all.
I cant have a logfile from a file that doesnt react at all.

#14 Updated by Miroslav Louma over 2 years ago

For me its not possible to attach a logfile because when i doubleclick the launcher exe, there is no reaction at all.
I cant have a logfile from a file that doesnt react at all.

Well, that is not correct. Launcher logging subsystem is able to log diagnostic messages even before any window is shown. So, in most cases, there should be a log file for you to upload. When launcher crashes without showing anything (main window or an error message), it is logical that you will not be able to find it in Task Manager (it starts, works for a short while and then crashes).

In rare cases, it is however possible that the launcher is unable to start in the first place. When this happens, no logging can be done (since no actual code of the launcher is executed) and thus no log files will be created. In order to determine, what is preventing from launcher to start, you should provide us with some diagnostic information:

  • dxdiag file:

http://forum.kingdomcomerpg.com/t/official-bug-reporting-guideline/27392

  • Windows event log:

https://support.kingdomcomerpg.com/issues/291#note-4

#15 Updated by Backer crapsody over 2 years ago

I was finally able to lockte the logfile and attached it too the thread.

#16 Updated by Miroslav Louma over 2 years ago

Unfortunately, that log file you have uploaded is same as sire404 has uploaded. That takes us nowhere, since we do not know, what exactly is failing in your case.

The launcher log files are created in system temporary directory (accessible via putting %TEMP% in File Explorer address bar), within subdirectory called GameLauncher (these files are not readable in text editor, so it's pointless to try doing so).

If you cannot find any files in directory mentioned above (or the directory does not exist), then it means that launcher does not start at all. You should provide us with the diagnostic information mentioned in my previous comment above.

#17 Updated by Backer crapsody over 2 years ago

Couldnt find anything related in the Eventmanager......

#18 Updated by Backer crapsody over 2 years ago

the only thing i found in the eventmanager is this.....

#19 Updated by Backer crapsody over 2 years ago

The problem was a username (Windows-username, with a special character. After changing this the launcher runs fine!!! :D

#20 Updated by Miroslav Louma over 2 years ago

We are glad that the launcher is working for you. It would however help us improve launcher, if we knew what exactly was causing this behavior. What was this special character (or characters)?

#21 Updated by Backer crapsody over 2 years ago

The special character was '

#22 Updated by Miroslav Louma about 2 years ago

  • Status changed from Investigating to Resolved

Also available in: Atom PDF