Project

General

Profile

Bug #369

[ArtemisWyrm] Try to install this game it stops 3/4 "This account already exists" error

Added by Backer urquhart about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Steam or Launcher:
Launcher

GameLauncher_20160601_230910_5618474.log Magnifier (525 Bytes) Backer urquhart, 06/08/2016 11:17 AM

GameLauncher_20160601_230852_2654145.log Magnifier (1.67 KB) Backer urquhart, 06/08/2016 11:17 AM

GameLauncher_20160601_230911_1037187.log Magnifier (2.28 KB) Backer urquhart, 06/08/2016 11:17 AM

KCD_Beta_Access_20160608131200.log Magnifier (16.1 KB) Backer artemiswyrm, 06/08/2016 09:22 PM

KCD_Beta_Access_20160608131200_000_KCD.log Magnifier (230 KB) Backer artemiswyrm, 06/08/2016 09:22 PM

History

#1 Updated by Tomáš Grünwald about 3 years ago

  • Status changed from New to Investigating
  • Assignee set to Miroslav Louma

#3 Updated by Miroslav Louma about 3 years ago

These are launcher log files. For this issue, we need to have a look at the installation log files. These log files are created in system temporary directory (accessible via putting %TEMP% in File Explorer address bar), the filename looks like this: KCD_Beta_Access_<date_and_time>.log.

#4 Updated by Backer artemiswyrm about 3 years ago

Miroslav Louma wrote:

These are launcher log files. For this issue, we need to have a look at the installation log files. These log files are created in system temporary directory (accessible via putting %TEMP% in File Explorer address bar), the filename looks like this: KCD_Beta_Access_<date_and_time>.log.

Here you go

#5 Updated by Miroslav Louma about 3 years ago

  • Private changed from No to Yes

We were finally able to reproduce this error and it seems that we have found a workaround that should get you out of this situation.

You need to create these two files at the original install location C:\Program Files (x86)\Warhorse Studios\KCD_Beta

  • system.cfg
  • version.txt

The content of these files does not matter (they can be empty). After that you have to uninstall the game. You should do it via Programs and Features dialog, however it entirely is possible that you will not see it there (which most likely, since the log files suggest that the entry there does not exist anymore).

If that is the case, you need to use this special command to uninstall it:

msiexec /x {DC804676-5720-4929-A988-4DC6DA85FE23} REMOVE=ALL /lv*x c:\kcd_uninstall.log

You need to enter this command in the command-line prompt (it does not have to be elevated, i.e. run as administrator, you will be prompted for that later on):

http://www.digitalcitizen.life/7-ways-launch-command-prompt-windows-7-windows-8

After the game is uninstalled, you should download latest launcher and install the game again. Installation should succeed.

We have already fixed this bug, when the game update installation fails, if the user has deleted any files before that. What you are experiencing is just a remnant of this bug.

If by any chance this workaround will not help you, that command above should create a log file (C:\kcd_uninstall.log). You should upload it here, along with installation log from the subsequent installation (if you manage to get there).

#6 Updated by Daniel Zadák about 3 years ago

  • Private changed from Yes to No

#7 Updated by Christian Piontek about 3 years ago

  • Status changed from Investigating to Resolved
  • Assignee changed from Miroslav Louma to Christian Piontek

Problem solved in a different way. :)

Also available in: Atom PDF