Project

General

Profile

Bug #308

Memory allocation failed

Added by Backer boogeyman42 over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Steam or Launcher:
Launcher

Description

When i started a new game the first times with the default settings the game always crashed during the video sequence. Then i set the video settings to the lowest possible and i got into the actual game. The more i move around, the more places i visit and the higher the graphic settings (especially for distances for objects and textures) are, the faster the game crashes, even on lowest settings after an hour or two. The error dialog says "***Memory allocation for xxxx bytes failed***".
During the game is running i can also watch my RAM (8gb) getting more and more filled until there's a overflow. When i load a savegame it runs again for indefinite period of time depending on graphic settings.

Is this actually a game issue or is 8gb of RAM simply too small (even for the final, optimized version)?

Some of the log files below contain the "Memory allocation failed" error and some don't.

KCD Build(1) 06 May 16 (20 44 56).log Magnifier (5.9 KB) Backer boogeyman42, 05/10/2016 11:09 PM

KCD Build(1) 06 May 16 (20 55 50).log Magnifier (5.84 KB) Backer boogeyman42, 05/10/2016 11:09 PM

KCD Build(1) 06 May 16 (21 03 14).log Magnifier (5.89 KB) Backer boogeyman42, 05/10/2016 11:09 PM

DxDiag.txt Magnifier (61.4 KB) Backer boogeyman42, 05/10/2016 11:09 PM

KCD Build(1) 07 May 16 (08 22 59).log Magnifier (5.91 KB) Backer boogeyman42, 05/10/2016 11:09 PM

KCD Build(1) 07 May 16 (09 30 40).log Magnifier (4.15 KB) Backer boogeyman42, 05/10/2016 11:09 PM

KCD Build(1) 09 May 16 (13 23 48).log Magnifier (4.2 KB) Backer boogeyman42, 05/10/2016 11:09 PM

KCD Build(1) 10 May 16 (09 46 43).log Magnifier (4.15 KB) Backer boogeyman42, 05/10/2016 11:09 PM

KCD Build(1) 10 May 16 (12 24 59).log Magnifier (5.9 KB) Backer boogeyman42, 05/10/2016 11:09 PM

History

#1 Updated by ProkyBrambora (QA Team) over 2 years ago

  • Assignee set to Tomáš Grünwald

#2 Updated by Tomáš Grünwald over 2 years ago

  • Status changed from New to Investigating

I am sorry for extreme delay.
While we suggest 16GB of RAM for beta, in reality 8GB should be enough - I tried it on my personal computer with 8GB several times and it was running quite good. But expect, it will be need to swap to disk a lot. Make sure, You have enabled swapfile with dynamic allocations and enough free disk space (The question is, what is it enough - I'd suggest at least 64GB). Also close all unnecessary programs before running the game - e.g. most of the screen capturing software interferes with rendering and may cause crashes. It is unprobabble, but possible, taht there is conflict with antivirus or another malware detection tools.
You may be already aware, that there are problems with save&load system in beta. After loading, there may happen just anything. Crashes are reported frequently.But if I understand Your report correctly, it is not Your problem - it is happening just after new game...

I'll pass Your log files to the programmers, maybe they'll invent something.

#3 Updated by Backer boogeyman42 over 2 years ago

Thank you for the answer.
In the meantime i found out that it had to do with the virtual memory (swap) settings indeed. The size was somehow set to 350mb, what is obviously too small so i set it to 12gb. Now the game runs for ever in the lowest settings and i can even switch to the very high settings without crashing instantly like it was the case before. At first i thought the problem would be fixed but the game still crashes after 1-2 houres with medium settings. Yes you understood it right, it has nothing to do with the save/load bug. My ssd is actually really full so it may be a problem of disk space. I will format my pc anyway over the weekend and upgrade to Win10. I assume that this will solve the problem anyway since it seems like it is no game issue, but a problem with my pc. I will give you an update when i have tested it.

#4 Updated by Backer boogeyman42 over 2 years ago

The problem is solved. The swapfile is dynamic now and with enough disk space the game runs without any problems and does not crash any more.
Thanks for the help.

#5 Updated by Tomáš Grünwald over 2 years ago

  • Status changed from Investigating to Resolved

Also available in: Atom PDF