Project

General

Profile

Bug #185

Launcher says I have the game even though install folder is empty, can't find files and won't re download.

Added by Backer alabie almost 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Steam or Launcher:
Launcher

Description

This is what I did:

I bought the game, downloaded the launcher, played the first beta fine the first time

Then the first patch came out and I ran the launcher but It would not download

@DrFusselpulli posted saying there was a new launcher, I downloaded it

Ran it and the game downloaded fully but I have no idea where, the install folder is empty

But now the game cannot find itself, and even if I delete the contents of the warhorse folder it still thinks the game is up to date

I've already tried deleting the KCD Beta folder in the registry too, no luck.

Easy solution: The launcher is checking a file somewhere that is saying I've already downloaded the game. Either tell me where this file is so I can delete it or just add a button to FORCE a game re-download when it fails to find game files. The latter is so easy to do it could have been a hot fix the same day I posted about the issue. Assuming the launcher is written in c++ or one of the languages a step up from it, the dialogue box is already there, the ability to start a download is already there. Perfect setup for a simple workaround. Add a button or just do another dialogue box after it fails asking if I'd like to download the game.

I hope this gets fixed! Been 3 weeks now :(

GameLauncher_20160421_190845_4085608.log Magnifier - Log file related to Bug #185 (957 Bytes) Backer drogna, 04/22/2016 02:17 AM

KCD_Uninstall_Bug.png - Screenshot of uninstall bug likely related to Bug #185 (165 KB) Backer drogna, 04/22/2016 02:23 AM

History

#1 Updated by ProkyBrambora (QA Team) almost 3 years ago

  • Assignee set to Miroslav Louma

#2 Updated by Miroslav Louma almost 3 years ago

Hi, we are really sorry that you are experiencing issues with the launcher.

In order to properly uninstall the game (along with the launcher), you should use standard procedure for uninstalling programs in Windows. This is done via Programs and Features dialogue

http://www.tenforums.com/attachments/tutorials/14618d1426605667-apps-uninstall-windows-10-a-uninstall_desktop_apps_in_programs_and_features-1.png

After that you should be able to reinstall the game via launcher. However, if the issue occurs again (game seems to be installed, but installation folder is empty), you should upload installation log file and log file created by the launcher itself:

The launcher log file is created in system temporary directory (accessible via putting %TEMP% in File Explorer address bar), within subdirectory called GameLauncher. These files are not readable in text editor, so it's pointless to try doing so.

The installation log file is created in system temporary directory as well, the filename looks like this: KCD_Beta_Access_<date_and_time>.log

#3 Updated by Miroslav Louma almost 3 years ago

  • Status changed from New to Investigating

#4 Updated by Backer drogna almost 3 years ago

Here is a log file from when this issue happens to me using the launcher time-stamped April 20th. I had uninstalled KCD and then downloaded a new launcher which would ask for credentials, check for launcher updates, game updates, state the game was up to date, but give the same error as in Alabie's screenshot when trying to run it. My Warhorse folder looks the same as his. When I try to use the 'Uninstall' button added to the April 20th launcher I get an error message which I took the following screenshot of:

#185" alt="Screenshot of uninstall bug likely related to Bug #185" />

#5 Updated by Miroslav Louma almost 3 years ago

Thanks for uploading the log file. Unfortunately, you have manually modified data in your registry, which now prevents proper uninstall of the game and launcher. We are still investigating a safe way to purge remaining data (from within launcher) on systems with corrupted installation metadata (such as yours).

Until then, possible workarounds include using System Restore to restore registry to a state before the corruption or reinstalling Windows.

#6 Updated by Backer drogna almost 3 years ago

I have been able to run the game by installing the launcher on a different machine, letting it download the game, then copying the game files over to my main machine. Whatever modification you see to my registry was done by running CCleaner(v5.16.5551) prior to generating the log file. I did not edit my registry manually such as with regedit.

#7 Updated by Christian Piontek over 2 years ago

  • Status changed from Investigating to Resolved
  • Assignee changed from Miroslav Louma to Christian Piontek

Also available in: Atom PDF